Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Need Premium Support?

ScaleOut Software offers customers several options for support and maintenance plans on a subscription basis for an annual fee.

Topics:

asked: Jun 06, 2017 at 05:49 AM

Seen: 327 times

Last Updated: Jun 06, 2017 at 05:33 PM

Unable to communicate to state server installed in server system from client.Is there any PS command to grant client cache access(ex: Grant-CacheAllowedClientAccount) or do we need to set any firewall settings(Inbound or outbound rules)?

I was getting below exception while running application: "Could not load file or assembly 'soss_dotnet2cli.dll' or one of its dependencies. The specified module could not be found."

I was able store data in state server when i run same application from server system.What is default port number used by state server to communicate?

more ▼

asked Jun 06, 2017 at 05:49 AM in Application Development

Raghu gravatar image

Raghu
1 2 5

(comments are locked)
10|5000 characters needed characters left

1 answer: sort voted first

If your application works fine when it runs on one of the state servers and does not work on remote client machine, it means your remote client is not properly configured. You should start with running ScaleOut StateServer (SOSS) installer on the client machine by selection the "Remote Client" installation option during the setup wizard. Then, you need to open SOSS Management Console and configure ScaleOut remote client library as it is outlined here:

http://static.scaleoutsoftware.com/docs/soss_help/content/anchor-managementconsole.html#_the_remote_client_configuration_pane

By default SOSS uses TCP ports 720-724 which have to be opened in you firewall configuration.
more ▼

answered Jun 06, 2017 at 05:33 PM

Support gravatar image

ScaleOut Support Team ♦
1.9k 19 20 20

(comments are locked)
10|5000 characters needed characters left